メモブログ

てきとーにはまった事などを記録します

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
  1. --/--/--(--) --:--:--|
  2. スポンサー広告

CPANをインストール

$ cpan
http://poccori.com/blog/wp/archives/90

cpanが入ったぽいので、
http://search.cpan.org/dist/WWW-Google-Cloud-Messaging/

メッセージモジュールをinstall
cpan[1]> install WWW::Google::Cloud::Messaging


//入っているか確認
i /WWW::Google::Cloud::Messaging/
Going to read '/var/root/.cpan/Metadata'
Database was generated on Mon, 28 Oct 2013 23:41:06 GMT
Module < WWW::Google::Cloud::Messaging (XAICRON/WWW-Google-Cloud-Messaging-0.03.tar.gz)
Module < WWW::Google::Cloud::Messaging::Constants (XAICRON/WWW-Google-Cloud-Messaging-0.03.tar.gz)
Module < WWW::Google::Cloud::Messaging::Response (XAICRON/WWW-Google-Cloud-Messaging-0.03.tar.gz)
Module < WWW::Google::Cloud::Messaging::Response::Result (XAICRON/WWW-Google-Cloud-Messaging-0.03.tar.gz)
Module < WWW::Google::Cloud::Messaging::Response::ResultSet (XAICRON/WWW-Google-Cloud-Messaging-0.03.tar.gz)
5 items found

make がないのかな。まだエラーが続く。
http://jake2.mbsrv.net/wordpress/?p=6

http://deepfolte.hatenablog.com/entry/20120225/1330129212
makeを入れてみるよ。

command line tool
http://d.hatena.ne.jp/january/20130722/1374478892
xcode > preference > general > download comandline tool

cpanを再度設定
cpan[1]> o conf init

手動でインストールすると
Warning: make not found in PATH[/usr/bin;/bin;/usr/sbin;/sbin;/usr/local/bin;/usr/local/git/bin]
ALERT: 'make' is an essential tool for building perl Modules. Please make sure you have 'make' (or some equivalent) working.

Where is your make program? []

makeがないみたいだが。

cpanを再度設定
cpan[1]> o conf init


Which YAML implementation would you prefer? [YAML]

Warning (maybe harmless): 'YAML' not installed.
Both YAML.pm and YAML::Syck are capable of deserialising code. As this
requires a string eval, which might be a security risk, you can use
this option to enable or disable the deserialisation of code via
CPAN::DeferredCode. (Note: This does not work under perl 5.6)

http://vlog.blog32.fc2.com/blog-entry-111.html
cpan YAML
make /yaml installされたか。

cpanを再度設定
cpan[1]> o conf init
これで今まで出てた。YAMLのwarningとかは出てこない。

cpan > install WWW::Google::Cloud::Messaging

->なんか実行されてるっぽい。
長い 数分かかってるイメージ

再度 perl xx.pl実行

---errorがかわった-----
# perl xx.pl
Can't verify SSL peers without knowning which Certificate Authorities to trust

This problem can be fixed by either setting the PERL_LWP_SSL_CA_FILE
envirionment variable or by installing the Mozilla::CA module.

To disable verification of SSL peers set the PERL_LWP_SSL_VERIFY_HOSTNAME
envirionment variable to 0. If you do this you can't be sure that you
communicate with the expected peer.

ソースの頭にSSLの設定を止める対応を行った
http://yassblog.blog.so-net.ne.jp/2011-08-25
$ENV{PERL_LWP_SSL_VERIFY_HOSTNAME}=0;

ok
スポンサーサイト
  1. 2013/10/29(火) 17:06:45|
  2. 未分類
  3. | トラックバック:0
  4. | コメント:0
<<再再申請 | ホーム | perlの実行 そしてGCM>>

コメント

コメントの投稿


管理者にだけ表示を許可する

トラックバック

トラックバック URL
http://barumemo.blog129.fc2.com/tb.php/63-2a5ded8c
この記事にトラックバックする(FC2ブログユーザー)
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。